ubuntu - 安装ruby 2.3.8 报错的解决办法

访问量: 56

参考:https://stackoverflow.com/questions/50085258/installing-ruby-2-3-x-on-ubuntu-18-04-is-causing-an-error-by-the-end-of-the-inst

今天安装的时候报错了。找了下日志,发现 是这个原因:

error: macro "EVP_MD_CTX_create" passed 1 arguments, but takes just 0
EVP_MD_CTX *EVP_MD_CTX_create(void);

解决办法
1。 sudo apt purge libssl-dev && sudo apt install libssl1.0-dev

2.  $ rbenv install 2.3.8 

就可以了。

订阅/RSS Feed

Subscribe

分类/category