ruby - ubuntu18 下面,编译ruby 的注意事项: gcc6

访问量: 72

参考:https://github.com/rbenv/ruby-build/issues/1146

另外,也参考:https://bugs.ruby-lang.org/issues/14076

需要安装 gcc-6 , 默认的gcc-7 会引起ruby 2.4以下的无法安装(?) 反正,如果要安装2.1.x 报错,那么就执行下面的:

# for ruby <2.4
apt install libssl1.0-dev
CC=$(which gcc-6) rbenv install `version`

# for ruby >2.4
apt install libssl-dev
rbenv install `version`

订阅/RSS Feed

Subscribe

分类/category