git - package-lock.json, yarn.lock 都应该被放到版本控制里

访问量: 349

参考: https://github.com/yarnpkg/yarn/issues/1583

目的:

1. 可以看到过去用到的历史版本

2. 可以更快的安装 (有一种优化的机制)

3. 对于yarn来说,可以严格的使用lock中的版本

但是也有人提出,在CI的过程中,会持续出现各种新的版本号,很影响,所以就不要commit. 

总之看情况灵活掌握

订阅/RSS Feed

Subscribe

分类/category