nodejs - 一定不要把版本弄混啊 否则会报奇奇怪怪的错误.

访问量: 94

特别神奇

这几天遇到个奇怪的错误: node14 安装的node_modules, 在node 16下面运行会报错

我之前用的nvm, 这个东东虽然可以自行切换版本(根据 .nvmrc ), 不过特别依赖与.nvmrc

所以切换成  asdf

asdf虽然跟nvm 作用一样,但是好处在于可以管理所有东东,包括 ruby ,postgres, nodejs, rust, 等等...

所以昨天果断卸载nvmrc, 使用asdf

问题好多了.

订阅/RSS Feed

Subscribe

分类/category